Microsoft Excel: SVERWEIS

In diesem Beitrag erläutere ich einmal die Funktion „SVERWEIS“ aus Microsoft Excel. Das folgende Beispiel soll zum besseren Verständnis dienen:

In den Zellen A1 bis C6 haben wir eine Tabelle mit unserem Warenbestand (Artikelnummer, Artikelbezeichnung und dem Preis). Jetzt möchten wir in der Zelle C11 eine Artikelnummer eingeben und dann sollen in den Zellen B16 die entsprechende Artikelbezeichnung und in C16 der Preis automatisch angezeigt werden. Dafür eignet sich die Funktion SVERWEIS.

sverweis1

Zur Erläuterung:
=sverweis($C$11 –> vergleiche Zelle c11
;$A$2:$C$6 –> mit dem Inhalt aus A2 bis C6
;2) –> bei Übereinstimmung gib den Wert der Spalte 2 aus, Spalte1=Artikelnummer, Spalte2=Artikelbezeichnung, Spalte3=Preis
(die $-Zeichen legen die Zelle als absoluten Wert fest, das heißt beim kopieren der Formel wird dieser Wert nicht verändert)

Wenn ich die Formel jetzt nach rechts kopiere um den Preis zu erhalten, wird uns nun wieder die Artikelbezeichnung ausgegeben. Das liegt daran, dass der Ausgabewert 2 (Spalte2) sich beim kopieren nicht automatisch auf 3 geändert hat. Dieses Problem lösen wir so:

Wir machen aus der 2 in der SVERWEIS-Formel Spalte(B2)

sverweis2

Nun noch ein wichtiger Punkt. Wenn wir nun eine Artikelnummer eingeben, die es in unserem Warenbestand gar nicht gibt, wird Excel uns den darüberliegenden Wert ausgeben.

sverweis3

Dies wollen wir natürlich nicht und ergänzen deshalb unsere Formel durch das Argument Bereich_Verweis, welches optional ist und schreiben hinter spalte(b2) ;FALSCH.

sverweis4

Nun wird uns #NV (nicht vorhanden) ausgegeben. Damit haben wir dann ein weiteres Problem, spätestens wenn wir Zahlen ausgegeben haben wollen mit denen wir dann weiter rechnen möchten. Wir müssen unsere Formel also noch einmal ergänzen. Für dieses Problem machen wir uns die Funktionen WENN und ISTNV zu nutze. Wir schreiben also vor unsere Formel =wenn(istnv(„unsere Formel“);0;“unsere Formel“))

sverweis5

Diese Formel sieht jetzt schon sehr kompliziert aus aber so schwer ist das gar nicht.

=WENN(ISTNV(SVERWEIS($C$11;$A$2:$C$6;SPALTE(B2);FALSCH));0;(SVERWEIS($C$11;$A$2:$C$6;SPALTE(B2);FALSCH)))

Also wir haben jetzt gesagt, wenn (WENN) das was in unserer Sverweis Formel steht nicht vorhanden ist (ISTNV) schreibe eine 0, sonst gebe uns den Wert heraus den unsere Sverweis Formel ergibt. Gebe ich also eine Artikelnummer ein, welche nicht in unserem Warenbestand vorkommt ergibt die Sverweis Formel #NV, dann bekommen wir die 0 sonst werden uns Artikelbezeichnung und der Preis angezeigt.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.